-1

Newer Version

We are on 1.8.9 and have been for he last 5 months for more. I think it's about time we got a newer version, wouldn't you agree?

Doesn't have to be the very latest version. I mean, the latest is 1.16.2, but maybe update it to 1.14 at least, so we get the village update.

#144 - Status: closed

1 month ago by AmazonAvenger for Improvements

Answer: Closed

Another suggestion of the same kind is already shortlisted.

3 weeks ago by Destitution_